Skip to content

UCU will be closed on Monday, July 4th, in observance of Independence Day.

 

A vulnerability has been reported by the Department of Homeland Security indicating that all systems and applications utilizing the Secure Socket Layer (SSL) 3.0 with cipher-block chaining (CBC) mode ciphers may be vulnerable [POODLE]. Because of this, we have disabled the SSLv3 protocol on our systems. Those using Internet Explorer version 6 will need to update your browser to a newer version of Internet Explorer. We continuously monitor our network and systems, and use platforms that have state-of-the-art encryption and security standards. As always, we recommend changing your passwords regularly and maintain a heightened awareness of sites and links you visit while using the internet. We will provide any further updates on this page.

Department of Homeland Security Announcement: https://www.us-cert.gov/ncas/alerts/TA14-290A