Skip to content

UCU will be closed on Monday, July 4th, in observance of Independence Day.

 

Microsoft recently announced that a security flaw in the Internet Explorer (IE) browser may put users at risk. The vulnerability exists in versions 6 through 11 of Internet Explorer. Microsoft has fixed the security glitch in their most recent update. If you have automatic updates enabled, it will update automatically. If you do not, we encourage you to apply the update manually as quickly as possible. If you are using Windows XP, we recommend using a different browser.

Other browser options:
Google Chrome
Safari
Mozilla Firefox

For more information about the flaw, please visit the Department of Homeland Security notice.